What are the minimum system requirements?

To get going on Dragon Go! download it to your iPhone 3GS, 4 or 5 or to your third and fourth generation iPod Touch (external microphone may be required).  Please note, Dragon Go! only likes to go on iOS 4 or later.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk